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1. LE-580FX Software Installation 
 
 
 
 
 

Setup program indicating LE-580FX 

Window(includes WinPcap) will be installed. 

Click Next  for next step. 

 

Please read license agreement. 

If confirm, please select accept option 

and click I agree  for next step. 

 

Please select installation of WinPcap or not. 

Click Next  for next step. 

Please check Destination folder and 

click Next  to begin the installation. 

<Notice> 
LE-580FX Window supports WinPcap Ver4.1.3. When you install the LE-580FX 
Window, WinPcap Ver4.1.3 will automatically be installed. If you have other version 
of WinPcap in your PC already, please uninstall it and then install LE-580FX 
Window. 
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Click Next to start the WinPcap installer. 

 

  

 

Read the License Agreement. Click I 

Agree  if you agree with the license. 

This window will appear when finishing the 

WinPcap installation. Clich Finish . 

Click Close to complete installation. 
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2. Main Window 
The top menus of LE-580FX include the following parts: File Menu, Edit Menu, View 

Menu, Capture Menu, Media Type, Statistics Menu, PG Menu, Tools Menu, and Help 

Menu. 

*Language (English/Japanese) is selectable from version 1.5. Invoke LE-580FX 

Window again after selecting the language. 

 

 

File Menu   

Menu Choice Usage 

Load Default 
Workspace 

Loads default system value. 

Load Monitor Log Loads monitored log(statistic information). 

Exit Exits LE-580FX Window. 

 

Edit Menu  

Menu Choice Usage 

Cut Cuts value 

Copy Copies value 

Paste Pastes value 
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View Menu   

Menu Choice Usage 

Alarm Info 

I
Invokes Alarm Info window. 

Control Window 

 

Invokes Control window. (default invokes) 
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Capture Menu  

Menu Choice Usage 

Capture Setup 

 

Setups Capture conditions for PortA and Port B. 

Capture Window 

 

Captures by conditions. 

Capture Option 

 

 

 

 

 

 

 
 

Selects analysis soft Ethereal or WireShark which will be started 
from the Capture window.(Default : Ethereal) 

(Ethereal and WireShark need to be installed.) 
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Media Type Menu  

Menu Choice Usage 

Media Type Invokes Media Type Setup window. 

                            

The Command  tab controls the selection of various speeds and 
modes. The NW-Ability  tab controls the use of auto-negotiation 
for advertising various speeds and modes.  

 

Set the conditions of each port in the PG mode. (Each port 
works independently) 

Set both ports as the same conditions in the TAP mode 
according to target device.  (When the condition is different, it is 
not able to communicate.) 

Default setting is Auto-Negotiation. 

Compliant version: LE-580FX Window V1.4/ FPGA V1.7 or later. 
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Statistics Menu   

Menu Choice Usage 

Meter (Dashboard) 

 

Provides communication conditions of Port A and Port B 
through dashboard.  

Meter (Threshold) 

 

Provides threshold configuration. 

Counter window 

 

Invokes Counter window. 
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The choices for the PG Menu  are described in the table below (for PG mode only): 

Menu Choice Usage 

Matrix Setup 

 

Invokes Matrix Setup window. 

X-Trailer 

  

Append X-Trailer and set offset value in the Tx tab and enable 
checking mechanism in the Rx tab. 

Flow Control 

 

Option for enabling Flow Control function of target port of LE-
580FX in PG mode. 

RxBERT 

 

Option for enabling BERT pattern check function of target port 

of LE-580FX in PG mode. 
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The choices for the Tools （“ツール”in Japanese ）Menu  are described in the table 

below: 

Menu Choice Usage 

IFG Converter 

 

Edits frame gap in the IFG Converter. 

Device Info 

 

 

Provides device information in the lower half of the Control 
window. 

FPGA Download Makes version up for FPGA. 

Language Changes the language from English to Japanese. Invoke LE-
580FX Window again after selecting the language. 

Note: After installing the LE-580FX Window, the initial display 
mode is in English on Windows OS of English version.  
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The choices for the Help Menu  are described in the table below: 

Menu Choice Usage 

About… 

 

Provides version information of both software of LE-580FX 
Window and firmware of LE-580FX.  

 

The buttons in the Main window tool bar are described in the table below: 

Figure Usage 

 Opens a saved file. 

 
Saves current file. 

 
Loads default workspace. 

 
Shows link established. 

 
Shows link not established. 

 
Shows link speed in 10M. 

 
Invokes Capture Setup window. 

 
Invokes Capture window. 

 
Invokes Dashboard. 

 
Invokes Counter window. 

 
Invokes Warning Information window. 

 Invokes Tile Horizontally window. 
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TAP mode is defaulted as the first operation of LE-580FX. When choosing PG/ NICA/ 

NICB mode, the Warning message will be shown for confirmation.  

 

 

 

 

 

 

 

 

3. Matrix Setup 
Go to the Main window top menu and choose PG=>Matrix Setup  to invoke the “Matrix 

Setup Window”.  

 

Use Matrix to edit a series of packets with various combinations to be transmitted 

sequentially.  

 

Click the ”Load Default”  button  to invoke the factory default for Matrix setting. 

There are 10 packets designed in the Matrix default setting.  

Click the “Load from file” button to load the saved Matrix file (excel format/mtx). 
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Click “Load from .dts file”  button to load the captured data (monitored network 

traffic and statistic information) in the “Matrix Setup Window”. 

Click the “Export to Excel File” button  to export current file into an Excel file. 

Click the  button. The Export to Matrix Mode  message box will be shown to save 

the captured file as a Matrix file (with extension “mtx”). This feature is helpful especially 

when a Matrix file is loaded into the other port without re-edit packets, or a Matrix file is 

reloaded into the current port when the current configuration is erased. 

 

 

 

 

 

 

 

 

Click the “Clear All”  button  to clean the window. This is the Matrix Setup window 

of Port B. 

Click “Add new frames” button  to add the new frames.(up to 128 frames) 

Click “Set Columns Width”  button  to adjust the width of “Matrix Setup Window”.  

: Start the packet transmission. 

: Stop the packet transmisson. 
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3.1 Edit Packet Pattern 

To edit packet pattern, click “Pattern” on the exact packet and the  button will be 

shown. Click the button to see the complete packet pattern.  
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This Frame Edit  window for the chosen packet will appear for more configurations.  

 

 

Move the cursor to the Frame Type tab to popup the menu for protocol type. 

In addition to Custom setting, you may choose other protocols, such as 

IPv4/TCP/UDP/ARP/IPX/ICMP/IGMP. 
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Please read the specification for each protocol setting. 

 

 

 

 

 

 

For Tags selection, choose “VLAN(Virtual Local Area Network)” or “MPLS(Multi-

Protocol Label Switching)”.  
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VLAN: Add the VLAN number as tag information in the frame(MAC frame) to  

distinguish the vertual LAN. 

MPLS: Add the label in the frame and make the forwarding faster.  

 

 

Choose “MPLS” and then MPLS dialog will appear. 

Choose the number of MPLS label. (up to 6)  
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Choose “Set Length” to edit packet length. Input the packet size from 48(min. size will 

be different in packet type) to 2000 in the “Input Box”. Or you can mark the packet data. 

 

 

 

 

 

(1) Mark the packet data where you want to change. 

(2) Choose “AA” as set pattern. 

(3) Click “OK” and go back to the Matrix Window. 

(4) Click “Apply Matrix Settings”. 
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At the column of Pattern (byte), the packet pattern will be changed accordingly. 

 

Mark the packets in the “Select” box which you want to transmit  

The total selected packets are indicated in the “Information” window. 

You can set other configuration as follow. Mark them if necessary. 

 

Append CRC: Add CRC 

CRC ERROR: Add CRC error 

Alignment Error: Add alignment error. 

Dribble Error: Add dribble error. 
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IP Checksum Error: Add IP checksum error. 

Click “Apply Matrix Settings” button every time you change the configuration. 

 

3.2 Other Configuration 

 

To send packets consecutively, choose “Continuous”  mode in the “Tx Mode”  pane. 

Or choose “Set Counter”  mode and input how many times you want to transmit. Up to 

65535 packets can be set as a batch. 

 

Your marked items in the Select All pane will be reflected to the transmission packets. 

 

 

Above is utility for inter-frame gap setup of selected entries. 

Select target entries, set Unit/ Rate and click “Apply” . It calculates the frame gap value 

and fills into selected entries individually. 

Unit:nsec,usec,msec,sec,packet/sec,%Utilization,DataBits/sec,FrameBits/sec,totalBits/
sec,BitTime 
Rate:100,95.45,90.32,85.28,80,75,70,65.12,60,50.08,50,45.04,40,35,30,25,20,15,10,5 
 

Select target entries and click “Pre-caluculate” to show the total transmitting rate of 

selected entries.  

Click  button to show values of Rate field in different units. 
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Check “Enable”  to transmit BERT. 

Please note, after TxBERT is being enabled, content of all generated packets are 

replaced with content of BERT except DA, SA, and Frame Type field. 

 

 
Mark “Enable ExBERT” in the “RxBERT” to check PRBS(2^23-1) in Rx. 

 

Use “IFG converter” to calculate the frame gap. 

Click “GET IFG Value” after setting of speed, Frame Size, Unit, Rate. The result(bit 

time) will be displayed in the right side. 

 

Mark on “Enable Flow Control” in the “Flow Control” to apply the flow control for 

Ethernet. 
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Tx X-Trailer is made to check whether the frame data is transmitted properly between 

LAN devices. You can insert checksum at the end of the data before CRC. By checking 

this checksum, you are able to know the consistency of the data. 

Normally, CRC is added at the end of frame. LAN devices, such as router and switch, 

count CRC again before transmission. If the data is altered accidentally because of bug 

etc., CRC will be made by the wrong information. And you may not able to find the 

problems in the CRC. 

If you use X-Trailer, you can insert 8byte of checksum before CRC. This checksum has 

the sequence numbers etc., and you are able to have further check. 

“DI Offset” need to be set for X-Trailer. For example, DI offset is 16, X-Trailer check 

data integrity for content of packets between 17th byte till end of packets(CRC is not 

included). 

 

Header CRCdata

Header data X-Trailer CRC

Header CRC
DI Offset

data
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To enable X-Trailer when receiving, mark on “Enable Rx X-Trailer”. 

Please note it is necessary to set the same DI offset setting for both transmit and 

receive of X-Trailer to make this function work correctly. 

You can check the result of X-Trailer in the “DI Checksum Error” or “Sequence Miss” in 

the Counter Window. 

 

 

  

4. Capture Setup Window 
Go to the Main window top menu and choose Capture=>Capture Setup  or simply click 

the Capture Setup  button  to invoke the Capture Setup window.  
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4.1 General  

 

In the “General”  Tab of the Capture Setup Window, there are “Capture setup” and 

“MAC address” table. 

 
In the Capture Setup pane, set packets receiving conditions to be captured and 

analyzed. Choose “Wizard”  to invoke the Wizard tab. Choose “All Packets”  to 

capture all packets. Choose “Advanced”  to capture Filter and Error conditions. 

Choose “Capture by size”  to capture lengths desired.  

 
In the MAC Address table, LE-580FX will automatically detect MAC address of on-line 
devices.  
 
 

4.2 Wizard 

 

To invoke the Wizard tab, select the box of Wizard . 
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Capture by MAC Direction 

 

Capture by IP Direction 

In the Wizard  Tab, choose layer 2 (MAC) or layer 3 (IP address) conditions to be 

captured by LE-580FX for analysis. Edit the range of packets to be transmitted or 

choose direction of transmission.  Choose Station1 or Staion2 and click “Any” button to 

set all addresses. 
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4.3 Filter setting 

 

To invoke the Filter tabs or trigger error conditions, select the box of Advanced . 

Mark on Filter1 and Filter2 in the “Advanced Setup” to popup the tabs for each filter. 

Only PG mode supports capturing error packets. 

(TAP mode captures all packets include error packets by marking on “All Packets”. 

Errors: 

� CRC Error (packets with FCS checksum error) 

� Alignment Error  (packets with FCS checksum error and 1 nibble less than setup 

length) 

� Dribble Error  (packets with correct FCS checksum but having an additional 1 

nibble attached) 
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4.3.1 Templates  

 
In the Template  Tab of the Filter Tab, choose protocol type and protocol contents(SIP, 

DIP, Src Port, Dst Port) for trigger condition of filtering.  
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4.3.2 User Definition 

Invoke the Setup  tab of Filter tab. Please note that this feature is also available in the 

TAP mode. If it is in the PG mode, click the TAP button in the Control window to switch 

mode. Choose the All User Defined option and the Setup tab will emerge. 

 

 

In the Setup tab of the Filter tab, choose UDF combinations and edit Length/ Offset/ 

Trigger/ Mask values (Mask values have to be set in bit). 

UDF1/UDF2 of trigger is up to 6byte and everything else is up to 4byte. Set don’t care 

setting as “0” in the mask. The one you marked in the “Select” will work. 

The following UDF combinations are available: 

UDF1 or UDF2 or UDF3 or UDF4 or UDF5 or UDF 6  

UDF1 and (UDF2 or UDF3 or UDF4 or UDF5 or UDF 6) 

UDF1 and UDF2 and (UDF3 or UDF4 or UDF5 or UDF 6) 

UDF1 and UDF2 and UDF3 and (UDF4 or UDF5 or UDF 6) 

UDF1 and UDF2 and UDF3 and UDF4 and (UDF5 or UDF 6) 

UDF1 and UDF2 and UDF3 and UDF4 and UDF5 and UDF 6  

(UDF1 or UDF2 or UDF3 or UDF4) and (UDF5 or UDF 6)  

(UDF1 and UDF2 and UDF3 and UDF4) or (UDF5 and UDF 6)  

(UDF1 and UDF2) or (UDF3 and UDF4 and UDF5 and UDF 6) 
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4.4 Capture by size 
In the Capture by Size  pane, packet size (X) can be set to be larger/ less/ in between 

 

user-defined bounds.  (The length ranges from 64(48) to 1536(2032) bytes in TAP(PG) 

mode.) 

Click “Apply” button after the configuration.  
 
<Important> 
Please click “Apply” button every time after the configuraion. 
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4.5 File to saving data 

     

 

You can select the file where you can save the packet data before capturing. 

Invoke Buffer tab in the “Capture setup” and click  to open the Select Default 

Directory window.   
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5. Dashboard 
Go to the Main window top-level menu and choose Statistics=>Meter=>Dashboard  or 

simply click the Show Diagram  button  to invoke the Dashboard.  

There are 4 parts for PG mode in the Dashboard: Port A Tx, Port A Rx, Port B Tx, and 

Port B Rx. And there are 2 parts for TAP mode: PortA->PortB, PortB->PortA.  

 

The three horizontal bars of each part show the rate of Packets/s, Utilization, and 

Errors/s, 

 

 

For the horizontal bars, red represents the data value is larger than the threshold value, 

green represents the data value is less than the threshold value. In this case, Utilization, 

and Errors/s do not exceed the threshold (they all green). 
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Click the Show Diagram button  to fold/unfold the Dashboard window. 

TAP mode: 
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PG mode: 

 

There are 2 individual tabs in Tx: Network and Collisions.  

And there are 4 individual tabs in RX: Network, Filter, Detail Errors, Size Distributions. 

 

In the Rx Network tab, 6 types of data (Rx Packets/s, Rx Utilization, Errors/s, Rx 

Byte/s, Broadcasts/s, and Multicasts/s) are shown. 
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In the Filters  tab, 4 Filter items (Filter1 Packet/s, Filter 1 Byte/s, Filter 2 Packet/s, and 

Filter 2 Byte/s) are shown. 

 

In the Detail Error  tab, 7 error types (TCP Checksum, IP Checksum, Alignment Error/s, 

Dribble Error/s, CRC Error/s, DI Error/s, and Sequence Miss/s (Series Error/s)) are 

shown.  

 

 

In the Size Distribution tab, 7 items (Undersize/s, 64-127 Bytes/s, 128-255 Bytes/s, 

256-511 Bytes/s, 512-1023 Bytes/s, 1024-1518, and Oversize/s) are shown. 

Represented in different color, the pie chart consists of various packet lengths.  
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In this case, DUT are sending packets with length in the range of 64 to 127 bytes, so 

the pie chart will be completely green.  

 

In the Tx Network tab, 4 types of data (Tx Packets/s, Tx Utilization, Collision/s, and Tx 

Byte/s) are shown. 

 

In the Collisions  tab, 5 collision items (Total Collision/s, Single Collision/s, Multi 

Collision/s, Ex Collision/s and Late Collision/s) are shown. 
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Click the Threshold button  to invoke the Threshold window, where various data 

can be set with a threshold value. To reset individual item, click the Reset  button. 

Reset All  button is for resetting all items.  

 

The data are checked per time that has been set at “Data Refresh Rate”. 

 

In this case, for better demonstration, threshold value for Bytes/s is changed to 

10,000,000. Click “Apply” button after configuration. 

 

When the sampled data reach the threshold, the time will be displayed in “Alarm info”.   

 

 

 

 

 

Alarm Info function assumes use of short period test until about 24 hours. 
It is not possible to long-term continuous measurement. 
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Example of using Dashboard: 

Connect LAN devices(DUT1, DUT2) into PortA and PortB of LE-580FX. Each data will 

be transmitted/received in the PortA and PortB. LE-580FX transmit captured data into 

PC. That data will be shown in the Dashboard. 

 

 

DUT1 DUT2

PortA => PortB

PortA <= PortB
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The vertical thin red line (pointed by the red arrow) indicates the time at which the data 

are sampled. In this case, white line symbolizes Rx Bytes/s, green line symbolizes Rx 

Packets/s, blue line symbolizes Errors/s, and yellow line symbolizes Utilization. The 

data having value larger than threshold value will be attached with a little alarming 

mark  next to the numbers.  

 

 

 

Click the Alarm Info  button  to invoke the window for Alarm Information. The data 

having value larger than threshold value will be shown in the Alarming Info. 

 

Click the Reset  button  to reset the Dashboard.  

 

 

 

 

 

 

 

Alarming 
Mark 
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Click the Save Meters Interval  button  to invoke the Save to Chart Files Interval 

window.  

 In this case, data will be saved into following as ALG file every 60 minutes (default):  

“C:\Program Files\LINEEYE\LE-580FX\LE-580FX Window v1.5b003\WorkSpace\user\Record 
\Monitor\20110310” 

Folder “20110310” will automatically made based on the date(year/month/day). 

Network tab, Filter tab, and Detail Error tab will be saved.  

You can load the file from Main Window top menu; File=>Load Monitor log  

 

Click the Refresh Timer  button  to invoke the Data Refresh Rate  window. In this 

case, the dashboard will be refreshed every second (default).   
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6. Counter Window 
Go to the Main window top menu and choose Statistics=>View Counter Window  or 

simply click the View Counter Window  button  to invoke the Counter Window for 

detailed statistics of selected ports.  

 

Click the Start Selected Port Counter  button  to start counting packets from the 

selected port. Click the Stop Selected Port Counter  button  to stop counting 

packets from the selected port. Click the Start All Counter  to start counting 

packets from all the ports. Click the Stop All Counter  to stop counting packets 

from all the ports. 

Click the Export to Excel File  button  to export the current file to an Excel file. 
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Click the Font Setup  button  to invoke the Font  window to adjust fonts. 

Click the Reset button  to reset the counter. 

To enhance user-friendliness, click the Item Select  button  to bring out the Row 

Selection  window to select specific items to show on the Counter window. 

 

Click the Hide Zero Rows  button  to remove items with 0 value to avoid confusion. 

Click the Adjust Column Width button  to adjust column width (in pixel). 

 

Click the Adjust Row Height  button  to adjust row height (in pixel). 

  

The range of packet size that is able to be count is from 52 to 2K bytes 
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7. Capture Window 
Go to the Main window top-level menu and choose Capture=>Capture Window  or 

simply click the View Capture Window   button to invoke the Capture window. 

 

The complete Ethernet packet for the protocol configuration will be demonstrated in the 

Capture window for in-depth analysis. Specifications of various protocols as well as 

packets contents are clearly displayed in hexadecimal and ASCII format. The Capture 

window is divided into the following three parts:  

 

Frame Display : The top area of the Capture View window contains a summary of 

each frame captured. 

 

Protocol Decode : The middle section of the Capture View window is a protocol-

dependent decode of the selected packet’s contents.  

 

Data Display : The bottom of the Capture View window shows the entire contents of 

the selected packet. The left hand column is the packet offset, expressed in 

hexadecimal. This is followed by sixteen bytes of data display, all in Hexadecimal, 

and the right hand column contains a display of the data in ASCII. 

 

In the Total Capture box in the Capture Window, there will be the total number of 

packets until capture end. Captured data will be saved automatically in every 500 

frames. The Page box tells you the which number of file is displaying now. 

Frame Display 

Protocol Decode 

Data Display 
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* LE-580FX Window(above v1.5) can save packets up t o 250,000,000(500,000 

files). 

Click the Start Capture  button  to start capturing data. Once the button is clicked, 

the following Warning  message will show to ask about deleting all files with certain 

prefix. Choose OK. If you do not want to delete the file, click Cancel and choose the 

folder to save. 

 

 

 

Click the Stop Capture  button  to stop capturing data. When stopping the capturing, 

it displays the packets of data file. 

Click the Next Page  button  to show the next data file. 500 frames will be saved at 

once in the Capture Window. To show more frames, you need to click this button.  

Click the Previous Page button  to display the previous data file. 

Click the Export to Excel File  button  to export current file to an Excel file. 

Click the  button to invoke Ethereal . (When Ethereal is selected by Capture 

option.) 

Click the  button to invoke Wire Shark . (When Wire Shark is selected by Capture 

option.)  

Click the  button to open former records by capture buffer. Data captured by the 

Capture window of LE-580FX can be saved in the place you set in the Buffer tab. 

 

 

 

 

 
The range of packet size that can be captured in TAP mode is from 64 to 1536 bytes(including CRC). 

And that in PG mode is from 64 to 1536 bytes. Because of the limitation of PC performance and Networks, 

the ability of LE-580FX window in capturing is not well as Wireshark or Ethereal. 

Wireshark and Ethereal are recommend in capturing packets. 

Please do not install WinPcap when installing Wire Shark or Ethereal. 
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Meaning of status: 
           Delta(us) : Time from receiving previous packet until receiving next  

packet (unit:1us. Max: 57minutes). 
           Length : packet size (byte) 
 (TAP mode does not include the size of CRC, but in PG  
 mode includes it.) 
           DA : MAC address of transmission in hexadecimal. 
           SA : MAC address of receiving in hexadecimal. 
           Ether : either of DIX Ethernet II or IEEE 802.3 frame 
           Protocol : Protocol type 
           Data : frame in hexadecimal in dump display. 
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8. NIC Mode 
LE-580FX will act as pure network interface card with Auto-MDIX supported. When 

only one port is connected to network while the other port is left empty, it could be 

performed normal network activities (sending e-mail, browsing the internet, etc) without 

LE-580FX window control. (MAC address is shown in the bottom of the product) 
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